System unavailable: Conector APP 341
Incident Report for PagBank
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 10:15 GMT-03:00
Investigating
We are investigating the problem
Posted Apr 16, 2024 - 10:10 GMT-03:00